doc / ch.tutteli.atrium.spec

Package ch.tutteli.atrium.spec

Helper functions for specifications as well as the contract of IAssertionVerbFactory.

Types

IAssertionVerbFactory

interface IAssertionVerbFactory

Functions

check

fun <ERROR CLASS>.check(description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>

checkGenericNarrowingAssertion

fun <T> <ERROR CLASS>.checkGenericNarrowingAssertion(description: String, act: (T.() -> Unit) -> Unit, lazy: T.() -> Unit, vararg otherMethods: <ERROR CLASS><String, T.() -> Unit>): <ERROR CLASS>
fun <T> <ERROR CLASS>.checkGenericNarrowingAssertion(description: String, act: (T.() -> Unit) -> Unit, vararg methods: <ERROR CLASS><String, T.() -> Unit>): Unit

checkNarrowingAssertion

fun <T : Any> <ERROR CLASS>.checkNarrowingAssertion(description: String, act: (IAssertionPlant<T>.() -> Unit) -> Unit, lazy: IAssertionPlant<T>.() -> Unit, vararg otherMethods: <ERROR CLASS><String, IAssertionPlant<T>.() -> Unit>): Unit

inCaseOf

fun <ERROR CLASS>.inCaseOf(description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>

prefixedDescribe

fun <ERROR CLASS>.prefixedDescribe(prefix: String, description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>

setUp

fun <ERROR CLASS>.setUp(description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>