doc / ch.tutteli.atrium.spec

Package ch.tutteli.atrium.spec

Helper functions for specifications as well as the contract of AssertionVerbFactory.

Types

AssertionVerbFactory

interface AssertionVerbFactory

Functions

check

fun <ERROR CLASS>.check(description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>

checkGenericNarrowingAssertion

fun <T> <ERROR CLASS>.checkGenericNarrowingAssertion(description: String, act: (T.() -> Unit) -> Unit, lazy: T.() -> Unit, vararg otherMethods: <ERROR CLASS><String, T.() -> Unit>): <ERROR CLASS>
fun <T> <ERROR CLASS>.checkGenericNarrowingAssertion(description: String, act: (T.() -> Unit) -> Unit, vararg methods: <ERROR CLASS><String, T.() -> Unit>): Unit

checkNarrowingAssertion

fun <T : Any> <ERROR CLASS>.checkNarrowingAssertion(description: String, act: (AssertionPlant<T>.() -> Unit) -> Unit, lazy: AssertionPlant<T>.() -> Unit, vararg otherMethods: <ERROR CLASS><String, AssertionPlant<T>.() -> Unit>): Unit

describeFun

fun <ERROR CLASS>.describeFun(describePrefix: String, funNames: Array<out String>, funNamePrefix: String = "`", funNameSuffix: String = "`", body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>

describeProperty

fun <ERROR CLASS>.describeProperty(describePrefix: String, propertyNames: Array<out String>, propertyNamePrefix: String = "`", propertyNameSuffix: String = "`", body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>

inCaseOf

fun <ERROR CLASS>.inCaseOf(description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>

prefixedDescribe

fun <ERROR CLASS>.prefixedDescribe(prefix: String, description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>
fun <ERROR CLASS>.prefixedDescribe(prefix: String, suffix: String, description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>

setUp

fun <ERROR CLASS>.setUp(description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>