doc / ch.tutteli.atrium.spec / IAssertionVerbFactory

IAssertionVerbFactory

interface IAssertionVerbFactory (source)

Functions

checkException abstract fun checkException(act: () -> Unit): ThrowableFluent
checkImmediately abstract fun <T : Any> checkImmediately(subject: T): IAssertionPlant<T>
checkLazily abstract fun <T : Any> checkLazily(subject: T, createAssertions: IAssertionPlant<T>.() -> Unit): IAssertionPlant<T>
checkNullable abstract fun <T> checkNullable(subject: T): IAssertionPlantNullable<T>