doc / ch.tutteli.atrium.spec

Package ch.tutteli.atrium.spec

Types

IAssertionVerbFactory interface IAssertionVerbFactory

Functions

check fun <ERROR CLASS>.check(description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>
checkGenericNarrowingAssertion fun <T> <ERROR CLASS>.checkGenericNarrowingAssertion(description: String, act: (T.() -> Unit) -> Unit, immediate: T.() -> Unit, lazy: T.() -> Unit, vararg otherMethods: <ERROR CLASS><String, T.() -> Unit>): Unit
checkNarrowingAssertion fun <T : Any> <ERROR CLASS>.checkNarrowingAssertion(description: String, act: (IAssertionPlant<T>.() -> Unit) -> Unit, immediate: IAssertionPlant<T>.() -> Unit, lazy: IAssertionPlant<T>.() -> Unit, vararg otherMethods: <ERROR CLASS><String, IAssertionPlant<T>.() -> Unit>): Unit
checkNarrowingNullableAssertion fun <T> <ERROR CLASS>.checkNarrowingNullableAssertion(description: String, act: (IAssertionPlantNullable<T>.() -> Unit) -> Unit, immediate: IAssertionPlantNullable<T>.() -> Unit, lazy: IAssertionPlantNullable<T>.() -> Unit, vararg otherMethods: <ERROR CLASS><String, IAssertionPlantNullable<T>.() -> Unit>): Unit
inCaseOf fun <ERROR CLASS>.inCaseOf(description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>
setUp fun <ERROR CLASS>.setUp(description: String, body: <ERROR CLASS>.() -> Unit): <ERROR CLASS>