doc / ch.tutteli.atrium.spec / AssertionVerbFactory

AssertionVerbFactory

interface AssertionVerbFactory

Functions

checkException

abstract fun checkException(act: () -> Unit): ThrowableThrownBuilder

checkImmediately

abstract fun <T : Any> checkImmediately(subject: T): AssertionPlant<T>

checkLazily

abstract fun <T : Any> checkLazily(subject: T, assertionCreator: Assert<T>.() -> Unit): AssertionPlant<T>

checkNullable

abstract fun <T> checkNullable(subject: T): AssertionPlantNullable<T>