doc / ch.tutteli.atrium.spec / ForgivingTest

ForgivingTest

class ForgivingTest (source)

Represents a TestScope which accepts AssertionError but fails for any other exception.

Constructors

<init>

ForgivingTest(test: <ERROR CLASS>)

Represents a TestScope which accepts AssertionError but fails for any other exception.

Properties

parent

val parent: <ERROR CLASS>

Functions

execute

fun execute(context: <ERROR CLASS>, dynamicTestExecutor: <ERROR CLASS>?): <ERROR CLASS>

getType

fun getType(): <ERROR CLASS>