class DeprecationTestEngine
(source)
Represents a TestEngine (id 'spek-deprecation') which uses the SpekTestEngine but allows to define tests which shall be converted to ForgivingTests.
Which tests shall be forgivable can be defined with the custom config property forgive
and a regular expression
matches desired UniqueIds. For instance:
forgive=.*\.Iterable\..*
Turns all tests containing .Iterable.
in their UniqueId into a ForgivingTest.
Moreover, the engine fails if no tests were discovered or if an error occurs during discovery.
DeprecationTestEngine()
Represents a TestEngine (id 'spek-deprecation') which uses the SpekTestEngine but allows to define tests which shall be converted to ForgivingTests. |
fun discover(discoveryRequest: <ERROR CLASS>, uniqueId: <ERROR CLASS>): <ERROR CLASS> |
|
fun execute(request: <ERROR CLASS>): <ERROR CLASS> |
|
fun getId(): String |